Asset Escrow download errors

Incident Report for Cfxre

Resolved

While our upstream provider is still facing issues, we've mitigated the issue for now. Have a great day, everyone!
Posted Jul 01, 2025 - 19:49 UTC

Monitoring

We've implemented a temporary solution while we wait for our upstream provider to recover. You should be able to download your assets now, but there might be some delays or issues. Once the upstream provider recovers we'll make additional adjustments.
Posted Jul 01, 2025 - 18:44 UTC

Identified

One of our upstream provider is currently experiencing an outage in one of their datacenters.
Posted Jul 01, 2025 - 16:33 UTC

Investigating

We are aware of issues with our content delivery service for escrowed assets and are actively investigating.
Posted Jul 01, 2025 - 16:06 UTC
This incident affected: Game Services (Keymaster) and Web Services (Portal).