CnL Performance
Incident Report for Cfx.re
Resolved
This incident has been resolved.
Posted Aug 08, 2023 - 23:04 UTC
Investigating
We are currently investigating an issue affecting CnL performance.
Posted Aug 08, 2023 - 17:25 UTC
This incident affected: Game Services (CnL).